User Tools

Site Tools


install_htop

Install htop

2016

htop provides a graphical view of processor and memory capability and usage. It is pretty handy on the MFEL to work out if the limit of the processor(s) is being reached. It's a much more capable indicator of resource usage than the MFEL GUI performance indicator.

If wget is not installed/working


If the wget command is not available, or not working, you can try curl as an alternative, check out this page for syntax Use Curl as wget Replacement

Install Htop Using Binary Packages in Linux


To install Htop on RHEL 7/6/5 and CentOS 7/6/5, your system must have EPEL repository installed and enabled, to do so run the following commands on your respective distributions to install and enable it for your system architecture (32bit or 64bit).

On RHEL/CentOS – 32-bit OS


————– For RHEL/CentOS 6 ————–

  wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
  rpm -ihv epel-release-6-8.noarch.rpm

————– For RHEL/CentOS 5 ————–

  wget http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
  rpm -ihv epel-release-5-4.noarch.rpm



On RHEL/CentOS – 64-bit OS


————– For RHEL/CentOS 7 ————–

  wget http://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-8.noarch.rpm
  rpm -ihv epel-release-7-8.noarch.rpm 

————– For RHEL/CentOS 6 ————–

  wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
  rpm -ihv epel-release-6-8.noarch.rpm

————– For RHEL/CentOS 5 ————–

  wget http://download.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
  rpm -ihv epel-release-5-4.noarch.rpm



Once EPEL repository has been installed, you can hit the following yum command to fetch and install the htop package as shown.

  yum install htop


On Fedora OS


Fedora users can easily install htop using Fedora Extras repository by typing:

  yum install htop
  dnf install htop      [On Fedora 22+ releases]


On Debian and Ubuntu


In Debian and Ubuntu, you can fetch htop by typing:

  sudo apt-get install htop



Error: xz compression not available


If you get the error:
Error: xz compression not available
Then it is due to an EPEL libarary mismatch, and you will have to remove the EPEL and reinstall it.

The code below will help, but you need to know what version to remove and to install. Just try to remove any version, if its wrong you will get an error, the error will tell you the currently installed version.

  sudo rpm -e epel-release-7-5.noarch
  wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
  sudo rpm -ivh epel-release-6-8.noarch.rpm
  sudo yum clean all
  sudo rpmdb -v --rebuilddb
  sudo yum -y install libselinux-python



install_htop.txt · Last modified: 2017/02/28 18:00 (external edit)