User Tools

Site Tools


cisco_configuration_ttl

Cisco Configuration



Cisco 3560 Configuration Guide for iSIS8000 Systems


Introduction (download full document here cisco_configuration_guide.pdf )

The following document deals purely with the configuration of 3560 switches used in ISIS8000 systems under nCC V5 control. It covers both TS data and TS output switches.

Cisco switches are becoming more and more common in TANDBERG systems as they are used to interface various products to customer IP networks. The switches can be used in many roles with in the system. The following document is designed to assist setting up Cisco equipment for use with nCompass Control and iSIS8000 systems.

This document gives an overview of all the functions associated with Cisco switches when used with nCompass Control. The document is only to be used as a guide to assist engineers in setting up and configuring switches. The following instructions for setting up switches in the following modes are covered:-

  1. TS Data switch
  2. TS Output switch

Switch Types


Cisco switches can be used in nCompass Control to carry broadcast traffic over IP. nCompass can currently control specific Cisco switch models for device redundancy. The operation of the switch is controlled by SNMP.

nCompass can currently support the following switches for device control:-

  • Cisco 3550/60 Series (3560 for iSIS8000)
  • Cisco 4500 Series


There are currently two software versions available on the Cisco 3550/60. There is no difference in hardware between an SMI and EMI switch. The two software versions are Enhanced Multilayer Image (EMI) and Standard Multilayer Image (SMI). EMI provides more features such as enhanced security, Quality of Service (QoS), OSPF Routing and Protocol Independent Multicast (PIM). IP streamer and encoder systems can use an SMI switch unless specified otherwise.

Cisco 2950 switches are used for Management network redundancy only.


Initial Switch Configuration (3560)


The following is intended as a guide to configure Cisco catalyst switches to work with nCompass. If a GigE switch (i.e. Cisco 3560G) is being used the replace all instances of fa0/? With gi0/?

  • <R> denotes the Return key.
  • Switch> Prompt is the base menu.
  • Switch# Prompt is the enable menu (type ‘en’ and password (if one is set) to get to this point from initial prompt). Type end to return to Switch>
  • Switch(Config) Prompt is the configure mode. Type ‘conf t’ from enable menu, type ‘end’ to exit to enable menu.
  • Switch(Config-IF) Prompt is a typical sub configuration menu. Type int fa0/1 to get to this point type ‘exit’ to return to Switch (Config) or ‘end’ to return to enable menu (Switch#)
  • In the enable menu (Switch#) type ‘sh ru’ to view the existing configuration.
  • The TAB key can be used to complete words i.e. sw <TAB> will complete to switchport etc.
  • The up or down curser can be used to recall earlier commands for that menu. (Hyperterminal may prevent this if not set correctly. This feature will always work with Telnet).
  • To cancel a command type ‘no [command]’ <R>.

TS Data Switch setup

The following gives a brief set of instructions for setting up a Cisco 3560 as a TS Data switch. Clearing the Current Configuration

This is recommended if the switch has been previously used.

  1. Connect to switch using console port on rear of unit.
  2. Open a HyperTerminal session for 9600 8N1N.
  3. Type ‘en’ <R> for enable.
  4. Enter the enable password (default ‘cisco’) if applicable then <R>.
  5. Type ‘erase startup’ <R>
  6. You will be given a warning about erasing the nvram press <R> to confirm
  7. Press <R> again.
  8. Type ‘reload’ to reboot switch.
  9. You will be asked to “Proceed with reload” press <R> to confirm
  10. 1The switch should now start in the default configuration this will take a few minutes and will involve the reloading of flash.
  11. After reload is complete you will be asked to press <R> to begin, once this is done you will be asked to type “yes” or “no” to enter the initial configuration dialog, type “no” <R>
  12. This will then put you at the switch> prompt
  13. Type “en” <R> this will put you at the switch# prompt where commands can be entered
  14. Type “show ru” this will show the current config, which should look like the following text (comments are in capitals and brackets)



Current configuration : 1312 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch (DEFAULT HOSTNAME)
!
!
no aaa new-model
ip subnet-zero
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1 (NO VLAN’S ASSIGNED)
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
no ip address
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end
Switch#

Typing in the TS Data Switch Configuration


  1. At the “switch#” prompt type “conf t” <R> to allow config parameters to be entered.
  2. At the “switch(config)#” prompt type the following and press <R> after each line. Ignore any warnings following the “spanning-tree port fast” command. Any mistakes will be shown by a rejection of the command and a marker will show the illegal character(s).


interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast
no cdp enable

REPEAT FOR EACH INTERFACE AN ENCODER WILL BE CONNECTED TO


To configure a group of interfaces, use the range command

  interface range GigabitEthernet 0/1-12



!
interface GigabitEthernet0/24
no switchport
ip address 10.1.4.245 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description Multicast Source
!
!
ip classless
!
ip route 0.0.0.0 0.0.0.0 10.1.4.254
OPTIONAL GATEWAY ADDRESS FOR VLAN 10
!
!
snmp-server community public RO
snmp-server community private RW
!
control-plane
!
!
line con 0
line vty 0 4
password cisco
line vty 5 15
password cisco
!
end



After typing “end” above you will be returned to the “switch#” prompt. The final thing to do is to enable IGMP snooping on the switch

IGMP snooping can be enabled on a switch to prevent a particular port being exposed to all multicasts on a network. For example suppose there where 100 5MBits multicast streams on the back plane of the switch and you connect a device with only a 10/100 baseT port then it will be unable to tune into a multicast since it will just see a mass of packets (broadcast storm). In order to prevent this the switch can listen into multicast joins and hosts and only allow specific multicast traffic to a port if a receiver attached requests it.

IGMP snooping is normally configured as a global command but can be assigned to specific interfaces. To configure IGMP on for the entire switch.

  1. Enter the enable menu by typing ‘en’ <R> to get to the “switch#” prompt
  2. Type ‘conf t’ <R> to enter configure mode and enter a password if needed
  3. Type ‘ip igmp snooping’ <R> This enables IGMP snooping on all ports



cisco_configuration_ttl.txt · Last modified: 2023/03/09 22:35 by 127.0.0.1